aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorgarret <garret@airmail.cc>2024-07-07 19:24:13 +0100
committergarret <garret@airmail.cc>2024-07-07 19:40:28 +0100
commita1c7e13e93da0907c562ac36910739f5be3de55c (patch)
tree647b7fb6b8195cf66886786bf08a945eb6ba1c5d /pyproject.toml
parent006da1f7e73675d01229e0b17513284c44ca17cc (diff)
downloadyt-dlp-rajiko-a1c7e13e93da0907c562ac36910739f5be3de55c.tar.gz
yt-dlp-rajiko-a1c7e13e93da0907c562ac36910739f5be3de55c.tar.bz2
yt-dlp-rajiko-a1c7e13e93da0907c562ac36910739f5be3de55c.zip
load key from a file with pkgutil
wanted to do this before, but per comment: the official docs led me to believe that importlib_resources was the only way to do it, and that the thing i was trying to do wasn't supported in some python versions so i put it off to one side for later later came (now), and i tried to implement it with importlib.resources didn't work, i looked it up and found this stackoverflow post https://stackoverflow.com/a/58941536 and the second answer, using pkgutil (not importlib.resources), just worked and the syntax/api seems much nicer as well have tested with pip yt-dlp + raw directory plugin, and binary yt-dlp + .whl plugin also on windows, with binary+whl both worked, amazing success! so pkgutil seems like the way to go i also updated the build thing to include .bin files in the extractor dir
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 7bfa824..eb9b2f4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,3 +17,6 @@ Homepage = "https://427738.xyz/yt-dlp-rajiko/"
[build-system]
requires = ["setuptools>=61.0"]
build-backend = "setuptools.build_meta"
+
+[tool.setuptools.package-data]
+"yt_dlp_plugins.extractor" = ["*.bin"]